Author Topic: Water system doesn't work  (Read 857 times)

0 Members and 1 Guest are viewing this topic.

Offline Iamaperson

  • New Poster
  • *
  • Posts: 5
  • Member since: 2022
  • I own a: Winnebago
  • Year: 1975
  • Model: Brave
  • Chassis: Dodge
  • Engine: 440
Water system doesn't work
« on: July 15, 2022, 12:22 PM »
Hi All. I have a 75 Brave and can't seem to get the water to work. I fill the tank in the back with the hose and nothing. Am I missing something?

Offline LJ-TJ

  • 18 year member
  • Top Post Contributor
  • *
  • Posts: 2630
  • Member since: 2003
  • I own a: a Motor Home
  • Year: 1975
  • Model: D21
  • Chassis: Dodge
  • Engine: 440-3
Re: Water system doesn't work
« Reply #1 on: July 15, 2022, 09:32 PM »
Did you turn the pump on after filling up the tank. Should be a switch on the wall.

Offline Iamaperson

  • New Poster
  • *
  • Posts: 5
  • Member since: 2022
  • I own a: Winnebago
  • Year: 1975
  • Model: Brave
  • Chassis: Dodge
  • Engine: 440
Re: Water system doesn't work
« Reply #2 on: July 27, 2022, 05:10 PM »
Yes. It makes a very loud noise and doesnt stop. Should it be doing that? Also the water doesnt come out when its on either. The manual says I need to close some kind of air relief valve. Where is that located?

Offline LJ-TJ

  • 18 year member
  • Top Post Contributor
  • *
  • Posts: 2630
  • Member since: 2003
  • I own a: a Motor Home
  • Year: 1975
  • Model: D21
  • Chassis: Dodge
  • Engine: 440-3
Re: Water system doesn't work
« Reply #3 on: July 27, 2022, 09:32 PM »
I'm guessing that you have the two galvanized pressure tanks. Mine a plastic tank with the sure flow pump. I'd pop up the back seat, turn the pump on and see if I couldn't see or feel were the air was coming out. It may be one of those little butterfly type valves. Hm?