Forum > Generators

I put a fuse in the 4.0k emerald I plus....

(1/1)

penskepartyof4:
Well it cranked, sputtered a bit til it got good fresh gas, then took off and leveled out idle. Provided 120v to the rig. It ran the a/c and microwave just fine. Kinda puffed out white smoke at first then settled down to not much smoke at all. I shut it off at the gen set.  Now it wont crank. Starter should be getting power. I started the rig and ran it incase the battery could not crank gen set over. I tried the gen set and it cranked super fast then stopped so I let go. Im guessing I blew something somewhere this time.

Earlier I took a switch out above the stove and replaced it. While putting it in I lost all power to it. I blew the fuse behind the whole panel that runs pumps and check tank levels and hood range fan. So I just hope, like Rick said, have some ground loops tripping out.

Oz:
I hope you can track it down quickly. 

penskepartyof4:
Thanks Oz  :)clap I even tried it inside and it did nothing. I went back out just 10 minutes before this post and for the  $@!#@! of it tried the inside one and the gen set cranked a couple whoops. I didnt want it to take off so the neighbors would complain. I will fire it up tomorrow to see if my fridge will do anything. I had the fridge say it would work on dc but it took forever to cool if it was even working. Idk. Now going to try propane then 120v off the gen set.

Is it normal for the microwave to flicker while the genset runs? I know the frequency thing. Was trained once.

penskepartyof4:
Ok.. SO... with AUX/house batteries on the genset cranks no problem. Now onto figuring out my issues with Mom(entary) and Dual button.

Navigation

[0] Message Index

Go to full version