Onan BGE - Only runs while holding the start button then shuts off when released

Started by Pargin4, August 15, 2020, 12:34 PM

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.


It's 965-0530. It definitely could be another carb, but I'm hoping not because the thing puffs oil smoke at startup and might not be worth much more than the price of a carb. According to the manual it came with a facet carb, but now has a nikki. I found the receipt where the po had it replaced. Still has the facet fuel pump.


I found this online resource I think from looking at Oz's links.


Is there any chance you will replace the carb? I will have to read on the stepping down from transformer to control voltage. I like to start with fluids then work into spark/electrical then air intake from there. Seems like you went that route. Could the carb not be set correctly if adjustable? I wonder if someone adjusted it and set it too far in on idle damaging it. I know you are very close to getting it to run all by its little old self. lol Just think of what else will shut it down and I would put money on another carb regardless. Then you can definitely eliminate that. My 2 cents.

I will be reading the manuals. If you let me know which genset is on the list from the link above or I can read it online; I will try to work along with you when you get back to it again. Hopefully one of us can help you that way.

OZ did never give nothing to the tin man, that he didnt already have. -America


I appreciate the help; i'll work on getting some pictures.
It's pretty much an under-the-floor model Onan Emerald I genset, model BGE spec A. When we bought the RV, the carb was off the genset and laying behind the driver's seat. I put it back on and tried to start it with no luck, so I dropped it out and rolled it in the garage. In there, I checked to make sure the fuel pump worked and it did. I checked for fire and there was none. I cleaned the points and got fire. There was no condenser at all so it got new points and condenser. Then it had fire but still would not start, even with direct battery voltage to the fuel pump and coil. I checked and there was some type of obstruction between the carb fuel inlet and the needle and seat. I blew through it with air. I held my hand over it just in case a check ball or anything flew out, but didn't feel anything. After that, it would run with direct voltage as above. I then checked that oil pressure switch and cleaned the slip rings and brushes a little. It ran but was loading up. I still have to deal with that. Either the float isn't floating, or the needle and seat aren't sealing. It gets a little gas running out of the carb horn. I didn't want to run it too much with it being rich like that, but I did want to see if I could get that AC voltage down into the acceptable range so I started running it and stepping the wires down on the transformer as the manual said to do. I was pretty sure I was going to be in range on the next time, but when I tried to start it, it was doing the whole "runs only when holding the start button" thing again.
I have an actual cleaning stone coming for the slip rings and if that makes it run again, I will probably invest in some new brushes and a carb kit.
For now, it has to sit because we're camping this weekend.


Could we get some pics of your genset? There have been ignition problems with some. Aftermarket solutions and OEM replacements in future models that work well.
OZ did never give nothing to the tin man, that he didnt already have. -America


Seems like you were trying some of these techniques. How did it go?

Take your oil pressure sensor wire off and ground it. Crank genset over.  Does it run now and not shut off?

Yes-> turn off and drain or change oil and filter. While empty, take out your oil pressure sensor. Clean your old oil pressure sensor with solvent of choice. Put it back in and refill oil and install oil filter. Does it run now and not shut down?

Yes-> Great! Plan to replace that oil pressure sensor soon but order it now and keep it with you when you travel.

NO? Really? More work needed. Isnt it fun?  :)rotflmao Many grounds is never enough!

I used to have a pocket full of relays when working on military gen-sets. Super easy to get them working again. Usually it was out of fuel or something a sensor shut it down for. Know what can shut your gen-set down and go through that list and fluids before and after every run-time.

I have heard that some gen-sets are tied into the rig gas tank. So if the gas tank is around 1/4 then the genset shuts down.  True? If it is, then you should be able to run on auxiliary gas tank or fill up your tank in your rig.
OZ did never give nothing to the tin man, that he didnt already have. -America


The following is what I was going off of, but I see now it isn't the same model as mine so your diagram may be the one I needed. Looks like they made the oil pressure switches both ways

Quote from: DaveVA78Chieftain on September 27, 2017, 08:14 PM
Model Onan 6.5 NH-3CR/14004P
Thats Spec P

The Onan Service manual is 900-0337.  Description of operation and schematic is on page 35 (pdf age 37) "Operation and Description BFA, BGA, and NH (Spec K - P)"

Oil pressure switch closes when oil pressure builds up.  If the oil pressure switch is disconnected, then the K3 run relay cannot be not energized to supply B+ to the ignition and fuel pump.  In this implementation, the charging voltage via CR1 charges the battery as well as supplies the run voltage to the ignition and fuel pump.

Onan Parts manual is 940-0222.

Both manuals are in the members area.


Will this help me or anyone out? I have yet to start my genset. Hell I dont think it will even start.

I have been trained in power generation. That being said it has been forever since I have worked on a genset. I have though worked on tons of small engines. I will be grounding the genset, while parked, directly to the ground. No opinions needed there. I want to know if I can run down the road with it running for the a/c? If so, how well will it be grounded to the chassis to keep it from frying my other circuits?

Most importantly! Since it hasnt ran in awhile; what steps do you recommend taking to get it ready to crank up? I have my own in mind I use for snow blowers to riding mowers and so on... I want to get that sucker running tomorrow and full a/c blowing while I rip into her to fix her up. I have not looked at wires and where they go from the genset or continuity to any of them. My inverter for dc is great. I dont want to F that up either. That being said, all your help is great to me!

OZ did never give nothing to the tin man, that he didnt already have. -America


Glad you got it running right without pulling out any more of your hair!
And thanks for giving us the update.
1969 D22, 2 x 1974 D24 Indians, 1977 27' Itasca


I never figured out the b1-b2 business, but I pulled the brushes and cleaned the slip rings just to see - and it took off and ran.
no-load voltage was like 190 or so though, so I've got to get that toned down before I can actually use it
baby steps


Ok, so it must be closing a relay. I couldn't find that in the diagram but then again the diagram leaves a lot to the imagination. Can't help with the generator side of things.


It is a single-wire switch - I've read in other posts where the resting state of the switch is open, then when the lubrication system pressurizes, it grounds. Since my initial post, I've verified that's how mine is working.
At this point I'm pretty sure it's the generator part that isn't working, and that's bad because it's the part I know absolutely nothing about. I see in the flight systems troubleshooting that I'm supposed to check voltage B1-B2. On the diagrams in the service manual, B1 is the wire to the starter on some diagrams pertaining to the control, but I don't see a B2 on those. In the actual generator section, there is a stator B1 and B2, with one of them going to that 2.5-ohm resistor and B2 from the ground tab. I think this is where i'm supposed to be checking voltage for that first few seconds it runs, but i'm not sure.


You "grounded" the LOP switch? That does not sound right. To test the switch you would connect the two wires together on a two wire switch. Not sure what pressure switch you have, the bigger Onans have a two wire switch. I will look up the diagram.

Looked at the manual but it is not real clear on the switch. It looks to me like the switch has two wires and if that is the case then I am guessing if you connect them together it will run. That is simulating a closed oil pressure switch. If that is the case you HAVE to verify that you do actually have oil pressure and that it is just a bad switch. Do not keep running it that way until you know for sure that you have oil pressure.


I have been reading posts about troubleshooting the BGE. I've downloaded the user, service, and parts manuals for it, and I downloaded the flight systems troubleshooting guide. I have the "starts but dies when you let off the start switch" condition that Flight Systems says is a common issue.
I applied 12V directly to the coil and fuel pump and the generator runs fine, but will not run on its own.
I replaced the printed circuit board and rectifier bridge -still fires with the start switch pushed in and dies when you let go..
I removed the shrouding around the oil filter and checked continuity of the LOP wire. It was good, so I attached it directly to ground - still fires with the start switch pushed in and dies when you let go.
I check the 2.5 ohm resistor as the manual said to do. It read 2.7. I kinda shook the generator to try to see if it was an intermittent connection, but it stayed solid.
Now I am to the point in the Flight systems guide that says to check voltage B1-B2. Where is a good place to access these?

thanks in advaince