Author Topic: 454 acts like it's not getting fuel  (Read 660 times)

0 Members and 1 Guest are viewing this topic.

Offline zekeielt

  • Test Driver
  • *
  • Posts: 4
  • Member since: 2020
  • I own a: a Motor Home
  • Year: 1987
  • Model: Elandan P37
  • Chassis: Chevrolet
  • Engine: 454
454 acts like it's not getting fuel
« on: July 21, 2020, 09:24 AM »
I just bought a 87 Winnebago elandan p37 with a 454.  As of yesterday, while driving it wants to act as though I am running out of fuel but if I shift to neutral or in park it revs up fine. I know i have gas in it. Thoughts?
First time RV owner so any helping hands are greatly appreciated!

Thanks,
Zeke

Offline skloon

  • Post Contributor
  • ***
  • Posts: 133
  • Member since: 2017
  • I own a: a Motor Home
  • Year: 1992
  • Model: SUNFLYER
  • Chassis: GMC
  • Engine: 454
Re: 454 acts like it's not getting fuel
« Reply #1 on: July 21, 2020, 09:25 AM »
Could be the fuel filter

Offline Rickf1985

  • 6 year member
  • Top Post Contributor
  • *
  • Posts: 5868
  • Member since: 2013
  • I own a: a Motor Home
  • Year: 1989
  • Model: Chieftain
  • Chassis: Chevy
  • Engine: 454
Re: 454 acts like it's not getting fuel
« Reply #2 on: July 21, 2020, 09:26 AM »
Fuel filter likely or electric pump in tank not running

Offline Sonny in Indiana

  • Test Driver
  • *
  • Posts: 2
  • I own a: a Motor Home
  • Year: 1999
  • Model: Brave
  • Chassis: Ford F53
  • Engine: Triton V 10
Re: 454 acts like it's not getting fuel
« Reply #3 on: July 21, 2020, 05:35 PM »
I had that exact issue in my 87.......I ended up dropping the fuel tank, and found the filter on the bottom of the fuel pump plugged.  plus, I found a second inline fuel filter that was kind of hidden up in the frame about half way between the tank and the engine, it was plugged also (I don't think it had ever been changed.  I cleaned the inlet screen on the fuel pump, replaced the "hidden" filter and it literally ran like a brand new motor!

Offline AliceKelly

  • Post Contributor
  • ***
  • Posts: 71
  • Member since: 2019
  • I own a: a Motor Home
  • Year: 1984
  • Model: Miniwinnie
  • Chassis: 1984 chevy g30
  • Engine: 350
Re: 454 acts like it's not getting fuel
« Reply #4 on: August 01, 2020, 03:35 PM »
I had this problem with my 350.  The fuel was getting heated and it was vapor locking.  I put a 5pound electric fuel pump up next to the tank and no more problems

Offline Rodib1

  • Test Driver
  • *
  • Posts: 5
  • Member since: 1
  • I own a: Winnebago
  • Year: 1989
  • Model: Super chief
  • Chassis: Chevy
  • Engine: 454
Re: 454 acts like it's not getting fuel
« Reply #5 on: January 12, 2022, 01:52 AM »
Did you figure out your problem? I’m in the same boat